Back to overview
Degraded

Network Latencies in Mumbai

Jul 29 at 11:47am IST
Affected services
MH NODE - 1
MH NODE - 2

Resolved
Jul 29 at 12:11pm IST

There was a glitch which caused network issue, it has been resolved now.

Created
Jul 29 at 11:47am IST

There are latencies and outages in Mumbai Region
Our provider is working on the issue. Update will be posted as significant progress is made.